phpMyAdmin의 임의의 PHP 코드 실행 취약점

phpMyAdmin의 임의의 PHP 코드 실행 취약점이 2009년 3월 24일 공개되었으며 해당 취약점과 관련한 내용은

아래 링크들을 참고하기 바란다.
 


해당 취약점은 phpMyAdmin 3.1.3.1 이전 버전과 2.11.9.5 이전 버전에 취약점이 존재하는 것으로
알려졌다.
2009년 6월 24일 SANS 블로그에는 phpMyAdmin의 해당 취약점을 공격하는 자동화된 툴이 발견되었다고 한다. 
자동화된 공격 툴이 발견된 만큼 이를 악용한 악의적인 공격도 증가 할 것으로 예측 된다.
 

현재까지 ASEC에서 해당 자동화된 툴에 대해 조사한 결과로는 발견된 자동화된 공격 툴은 총 2개 인
것으로 파악 되었다.

첫 번째 형태는 공격 대상이 되는 웹 사이트 URL을 입력하면 취약한 phpMyAdmin이 설치되어있는지
확인한 후 해당 취약점을 공격하여 해당 서버에서 특정 명령어를 실행 시킬 수 있는 형태이다.

두 번째 형태는 구글에서 특정 검색어로 검색한 후 검색 결과들에서 URL 주소들을 모두 수집한 후
그 중에서 phpMyAdmin을 찾아서 자동으로 공격해주는 형태이다.

phpMyAdmin에 존재하는 해당 취약점을 제거하기 위해서는 아래 링크에서 제공하는 보안 패치를
설치하는 것이 중요하다.

Categories:악성코드 정보

0 0 vote
Article Rating
guest
0 Comments
Inline Feedbacks
View all comments